[RESOLVED] Stuck on Publishing

Hello there,

I am creating a channel using exercises from the CK-12 and Khan Acamedy (English - US curriculum) public channels. On Sunday, 4 days ago, I tried publishing the channel (48 exercises containing one question each) and it has been stuck on 0% since. I am also unable to cancel as described in these posts:

Operating System (e.g. Windows, MacOS, Linux):
Windows 10
Browser (e.g. Chrome, Firefox, Safari):
Channel (Name of the channel you were working on):
EwB Revision :slight_smile:

Could someone help with this?

Hi @nikitab,

We’re currently experiencing issues with our task management system on Kolibri Studio, which sometimes causes tasks to get stuck. We’re working on several fixes and enhancements to resolve these issues.

I’ve manually updated your channel, so it should no longer be stuck publishing.


Thank you for unstucking me! I was able to edit the channel again and Studio seemed to run much faster. However, after editing for a while, Studio seemed to get much slower to a point where I could not delete or move resources. Could this mean that a process was stuck again?

I noticed that after moving a topic that I had copied to the clipboard, the topic was still available in the clipboard. I then tried to delete it from the clipboard and I got the “Deleting from clipboard…” notification for a very long time. Could this be a hint of a stuck process?

It seems that Studio runs faster again after I log out and log back in twice. However, the number of resources indicated for each topic is larger than the number of resources actually in the topic when I click on the topic. Could this be another symptom?

Maybe on a different note, I found that I cannot move an exercise into a topic that is empty. It does move it to the topic if I create a dummy exercise (so that the topic is not empty).

Thanks again for your support!

Hello there, I am trying to publish my channel again (EwB Revision :slight_smile: )and it has been stuck at 0% for 5 hours. Could you help unstuck it again? Thank you!

Hi @nikitab,

Your publishing task was queued, waiting for available workers for processing. It looks like it has completed now.

Yes, it was completed and imported properly in Kolibri. Thank you for your reply, Blaine!