Updated Studio Content Does Not Show Up in Kolibri Course

We have some teachers studying a teacher certificate course in Kolibri. They pointed out to me that one of the resources is showing as unavailable when they click on it. I logged in as an admin user and the content worked fine for me but when I used a learner’s login, the module still showed as unavailable.

I went to the Studio and removed the affected resource. I found that two of the resources were showing up as unavailable so I removed the second one as well and then published the course. After updating the course in our instance, I then went back and added the two missing documents back into the course.

Once I updated the course in our instance, I went to the class to add the two modules back into their proper place in the class. I found a message by the two resources I had removed shown in the attached screnshot. “Resource not found on device.” When I clicked the “Remove” button next to the resource, there was no response. I tried multiple browsers and there does not appear to be a way to remove the two missing resources. I’m also finding that the module adjacent to the missing resources (in this case the End of Module Quiz shown in the screenshot) continues to show up as unavailable to learners. With that in mind, I would like to be able to remove these two missing resources to see if it enables the rest of them to show up correctly for learners.

We are on version 0.14.7. Here’s a link to today’s log, in case that helps.

Does anybody have any ideas here that could help?

Hi @Andy_Johnson, thanks for your report and sorry for the delay in replying. This is a bug that our QA team also came across, and it has been updated with our most recent release, but unfortunately (as you have discovered), it is present on 0.14.7.

I will check in with the team and see if we can come up with a suggestion for you.


Hi again @Andy_Johnson – I know you have tried this on a few different browsers. Did you restart Kolibri as part of that testing? If you haven’t tried restarting yet, does the problem persist if you do so?

Thanks for your response, @marcellamaki! I was out of the country working on some other Kolibri projects but would like to circle back and get this one resolved. I have restarted our Kolibri server and the issue persists. Is our best bet to update our instance of Kolibri? We have almost 300 users accessing a teaching course right now so I want to make sure that we preserve their experience to the extent possible.

Hi @Andy_Johnson

Upgrading would definitely be an option that would fix the bug with removing resources that don’t exist, but the experience for using Kolibri as a learner for 0.15 is quite different, since updating the Learn experience was a major part of that upgrade. You can read an overview of the changes in our release blog post, if you haven’t seen this already so you can decide if this would work for you.

As an alternative, you could recreate the specific lesson with the new/updated resources you do want from scratch, remove the old one, and replace it with the new version.