Not able go past Kolibri loader after installation on Linux

Thanks for the great product, I am trying explore and run Kolibri in dev environment.


After installation when I run the dev server and access the URL http://—:8000 I see the kolibri loader and it does not go past that

Technical details

Version: 0.15
OS: Linux - Debian 2 CPU 2-GB-RAM, google cloud Compute Engine
Browser: Mozila, Google Chrome

On further checks I see an error “Uncaught ReferenceError: kolibriCoreAppGlobal is not defined”

I have followed the developer guide at readthedocs. Could you please to resolve.

I have got the same result on local ubantu18.04 VM created on widnows10.

Thanks for your help…

Best Regards,
Manish Deshmukh

Hi @Manish , could you share the commit hash of the Kolibri code you are trying to run?

Could you also share how you are invoking the Kolibri server? It sounds like you are running it without any frontend assets.

If you are running yarn run devserver then it seems like the frontend asset ports are being firewalled, and not accessible.

Hi Richard, Jonathan,

Many thanks for your emails. I applied a workaround; I built it and then used “yarn run python-devserver” and it’s running fine now for my purpose.

Yes the server was running without frontend assets - I was thinking it is due to that, it was trying to access the assets on localhost (http://localhost:*/**) and I was running it on google compute engine.

However as you mentioned below the ports were not open by default.

Do you think it’s a good idea to check with another install with required ports open on the server?

Best Regards,
Manish Deshmukh