Kolibri sometimes requests hashi html from port 0

When trying to use dynamic content, e.g. Blockly Games, Kolibri will request /content/static/hashi/hashi-cea3be36e609aeba234a13b27afd33b8.html from port 0, which fails with a connection refused and prevents the game from loading.

Restarting the system sometimes resolves the issue without making any other changes. Changing from no network to connected to a network sometimes resolves the issue. I am using the basic install of Kolibri that comes with latest Zorin EDU.

Technical details

Browser: Chrome 109.0.5414.74
Version: 0.15.7
OS: Linux-5.15.0-58-generic-x86_64-with-glibc2.33
Python: 3.9.9
Installer: Unknown
Server: Cheroot/unknown
Database: /home/student/.var/app/org.learningequality.Kolibri/data/kolibri/db.sqlite3
Free disk space: 35 GB
Server time: Sun Feb 12 2023 22:35:15 GMT+0200 (Central Africa Time)
Server timezone: Africa/Blantyre
Device ID: 728d412eed71d34d1e1f3fab700e1ed7

Hi @dkhardy ,

Thank you for reaching out to us with your technical issue.

In order to understand this better, I would request that you please look inside the KOLIBRI_HOME directory and post the contents of the server.pid file that is present there when it is running.



Apologies. I clearly am more of a noob with this than I thought. I cannot find where Kolibri is installed on my Zorin 16.2 EDU laptop using the Software app, that I believe is backed by snap. I don’t even see the environment variable for KOLIBRI_HOME.

I can run a ps and get:

k2tech@k2tech-ThinkPad-T470-W10DG:/usr/share$ ps -aux |grep kolibri
k2tech 7810 0.0 0.0 2600 540 ? S 19:47 0:00 /usr/libexec/flatpak-bwrap --args 40 kolibri-gnome
k2tech 7820 0.0 0.0 2988 1516 ? S 19:47 0:00 /usr/libexec/flatpak-bwrap --args 40 kolibri-gnome
k2tech 7821 0.3 0.6 107150068 102568 ? Sl 19:47 0:01 kolibri-gnome
k2tech 7850 0.0 0.0 2600 604 ? S 19:47 0:00 /usr/libexec/flatpak-bwrap --args 40 /app/libexec/kolibri-app/kolibri-daemon --session
k2tech 7866 0.0 0.0 2988 1620 ? S 19:47 0:00 /usr/libexec/flatpak-bwrap --args 40 /app/libexec/kolibri-app/kolibri-daemon --session
k2tech 7867 0.0 0.1 186056 30296 ? Sl 19:47 0:00 kolibri-daemon
k2tech 7879 13.3 0.5 2243224 92664 ? Sl 19:47 1:06 kolibri-daemon-http
k2tech 8309 0.0 0.0 18808 648 pts/0 S+ 19:55 0:00 grep --color=auto kolibri

Not sure if that helps or if you can give me some more guidance.


From the technical details you provided, the server.pid file should be in this directory:

I believe Zorin is using the Flatpak installer for this.

Thank you, sadly, there is no server.pid file in any of the org.learningequity.kolibri portion of the directory structure when kolibri is running.

Here are the contents of the folder…
k2tech@k2tech-ThinkPad-T470-W10DG:/home/student/.var/app/org.learningequality.Kolibri/data$ ls -l kolibri/
total 183436
drwxr-xr-x 5 student student 4096 Jan 20 03:13 content
-rw-r–r-- 1 student student 187625472 Jan 22 17:17 db.sqlite3
-rw-r–r-- 1 student student 53248 Jan 22 17:17 job_storage.sqlite3
drwxr-xr-x 3 student student 4096 Jan 22 17:17 logs
-rw-r–r-- 1 student student 40960 Jan 21 17:29 networklocation.sqlite3
-rw-r–r-- 1 student student 36864 Jan 20 02:05 notifications.sqlite3
-rw-r–r-- 1 student student 7302 Jan 1 1970 options.ini
-rw-r–r-- 1 student student 1439 Jan 20 02:05 plugins.json
drwxr-xr-x 10 student student 4096 Jan 20 02:05 process_cache
drwxr-xr-x 2 student student 4096 Jan 22 17:17 sessions
drwxr-xr-x 29 student student 4096 Jan 1 1970 static
-rw-r–r-- 1 student student 40960 Jan 20 02:05 syncqueue.sqlite3
k2tech@k2tech-ThinkPad-T470-W10DG:/home/student/.var/app/org.learningequality.Kolibri/data$ ls -l org.learningequality.Kolibri/
total 12
-rw-r–r-- 1 student student 8192 Jan 22 17:17 cookies.sqlite
drwxr-xr-x 2 student student 4096 Jan 21 13:13 localstorage

Hello, some new information.
While looking at the kolibri folder in the file explorer, I notice the server.pid was coming and going…
I was able to ope it and the contents are below:

Here is the netwrok error message…

Yes, that does seem like the appropriate zip port is not being set in the pid file, so that seems to be the root cause here.

That’s great that we have identified the root cause. What would be the fix to resolve this issue?

Hi @dkhardy - the Flatpak installer is maintained by the Endless Open Software Foundation, so I have referred this to them to investigate further. When I hear more, I’ll be sure to report back.

Kind Regards,

Any update on this issue?


Hi @dkhardy,

I discussed it with Endless Open Software Foundation and they have submitted a fix to Kolibri (although it only seemed to affect the Flatpak installer). We are hoping to release an update in the next week or so with the fix included.

I’ll loop back here when I’ve confirmed that the Flatpak has been updated.

Kind Regards,

Hi @dkhardy,

We have now released v0.15.12 which includes the fix for this issue. I have asked Endless Open Software Foundation to make a release of the Flatpak installer to make this fix available for Flatpak users as well. Hopefully this should be available in the next few days.

Kind Regards,

Thanks, Richard.

Still looking for it to be available on Zorin/Flatpak.


Hi @dkhardy! Sorry to leave you waiting here. I created a new release of the Kolibri flatpak today. It hasn’t been published yet because it needs to go through a bit of testing first, but if you’d to follow along, that’s happening over here: Update kolibri-gnome to 2.2.1 by dylanmccall · Pull Request #60 · flathub/org.learningequality.Kolibri · GitHub. If all goes well, it should appear as a regular update in the next day or two :slight_smile:

1 Like

Thanks All.

I got the update this morning on a dozen machines and have gone through some testing. All looks good to me.

Thanks to the community for keeping on top of this and getting a fix out so quickly.



Great, glad it appears to be resolved!