Kolibri failed to start. Additional information can be found

Recently I’ve started to get this problem but not sure why. It came by it self and I haven’t edited nor did anything to the settings of Kolibri. I tried installing Kolibri again (same way as updating) but nothing happened. Should I uninstall it and then install again?


When I open the log filed this is what I get:

WARNING 2020-01-30 05:19:50,449 options Ignoring unknown section in options file C:\Users\X.kolibri\options.ini under top level: Debug.
WARNING 2020-01-30 05:19:52,648 options Ignoring unknown section in options file C:\Users\X.kolibri\options.ini under top level: Debug.
WARNING 2020-01-30 05:21:38,580 options Ignoring unknown section in options file C:\Users\X.kolibri\options.ini under top level: Debug.
WARNING 2020-01-30 05:29:22,782 options Ignoring unknown section in options file C:\Users\X.kolibri\options.ini under top level: Debug.


Could it be that my options file was edited? I opened it and this is what I get. Not sure if that’s the default settings.

[Urls]
[Debug]
[Server]
[Paths]
CONTENT_DIR = D:\KolibriContent
[Deployment]
URL_PATH_PREFIX = /
[Cache]
[Database]

Hi,

Sorry to hear that you experienced this issue. What version of Kolibri were you running? Also, what version of Kolibri did you try reinstalling or updating with?

Could you please try removing [Debug] from the options.ini file, and then try starting Kolibri?

Thanks,
Blaine

I am sadly experiencing the same problem. I uninstalled and reinstalled Kolibri to get rid of this error. Removing the Debug file did not help.

Hi @goddamn_life and @Matthias -

Would you both mind looking to see if you have any additional errors inside either kolibri.txt or debug.txt?

Also, could you please confirm your operating system?

Thank you

Hello, I fixed my problem by uninstalling Kolibri completely and installing latest version again. I think this problem has to do with updating your Kolibri and keeping old content.

I use Windows 7 Ultimate 64 bit.

Hello, I fixed my problem by uninstalling Kolibri completely and installing latest version again. I think this problem has to do with updating your Kolibri and keeping old content.

Also don’t change the content file location alone you have to change the location of everything otherwise Kolibri would load endlessly. Change location of everything I mean the files in C:\Users(YOUR USERNAME).kolibri

In this page Change the Location of ALL Kolibri Files section it explains how to change the location.
https://kolibri.readthedocs.io/en/release-v0.7.x/manage.html

Hi, I’m glad to hear this worked for you!

However a couple notes:

  • You should not need to uninstall and re-install Kolibri. We are investigating this issue and hope to have a fix in a week or so as version 0.13.1 so that this will not be necessary.
  • The docs linked above are for an old version; the latest docs are available at https://kolibri.readthedocs.io/en/latest/

Thank you for your patience as we debug this.

I was able to reproduced this Windows 7 and the reason why kolibri can’t start is the options.ini file filled with incorrect values. I reported it on Github to fix this https://github.com/learningequality/kolibri/issues/6513

Hello @Matthias can I ask if you are also using an options.ini file - if yes, can you post the values of the ini file here so we can confirm the cause of your issue.

If not, could you please post the Kolibri version, logs, and the operating system here so we can debug it. Thanks.