Kolibri 0.15 "The media could not be loaded, either because the server or network failed or because the format is not supported"

If you have a specific technical inquiry, construct your post with the following:


Recently installed Kolibri v 0.15 to a new RPi400 with external SSD. RPi boots from SSD. Did a fresh download of Khan content to start using. Discovered that the videos do not play on any Apple device (iPad 2, iPad Air 2 with most current OS, MacBook Pro MacOS 10.15.7) under Safari. On the MacBook Pro, the videos will play in FireFox and Chrome.

Then, the same videos load and play in Chrome on an Android tablet.

I did not refresh the content on Kolibri Studio before downloading to our local Kolibri.

I’ve had this type of problem before with the older iPad 2, though it had been sorted out and they videos worked. Finding that even more current devices using Safari don’t load the videos is new.

Is there a change in the system that would make these videos not work across the board in Apple/Safari products?

I can’t swap Chrome/Firefox on the iOS devices to get around this problem as I could on the MacBook since iOS uses the same web kit from Apple for all the browsers.

Technical details

Version: 0.15.0
OS: Linux-5.10.63-v7l±armv7l-with-debian-11.2
Python: 3.7.3
Installer: deb kolibri - 0.15.0-0ubuntu1
Server: Cheroot/unknown
Database: /home/pi/.kolibri/db.sqlite3
Free disk space: 883 GB
Server time: Fri Jan 21 2022 17:26:48 GMT+0100 (WAT)
Server timezone: Africa/Lagos
Device ID: d93a1a1a5b780654997a121a2d1e5be6

Hi @cjackson,

Could you please share the specific video you were testing with? It sounds like an issue that’s popped up before due to browser differences in supporting different audio/video codecs within the MP4 container.


@blaine , Thank you for looking into this.

I’m in the process of rebuilding our Kolibri content as the previous database & content were corrupted. So, I’ve started from scratch. The content I’ve downloaded to our local Kolibri came from Studio that I’ve curated into subject/topic groups.

Basically, all of the Khan videos in early math/arithmetic in French and English, as well as English grammar lessons. That’s the extent of what I’ve downloaded thus far.

This is what I get from all of the videos when using iOS and Safari on MacOS

The content I’ve downloaded to our local Kolibri came from Studio that I’ve curated into subject/topic groups.

Did you curate this content on Studio?

Yes, that which I’ve downloaded thus are is from curated content on Studio.

Would you please direct message me the channel ID? You can find it in the URL on Kolibri Studio.

Yes. Here is are a few of them:




Thank you for sharing your channels.

After checking a few video resources, I’m fairly positive the issue is caused by unsupported audio codecs. I didn’t check all resources, but some French math videos within your channel use the amr_nb codec instead of aac. It does seem we’ve resolved this in the source Khan channels, but that does not automatically propagate to channels which have imported resources from them, like you have done with your curated channels.

I recommend performing a sync of the file resources. You will have to publish and re-import the channels into Kolibri afterwards.

Please let us know if this resolves your issue.


1 Like

@blaine : Thank you for this detective work. I’ll do as you have suggested and will get back to you.

@blaine I did as you indicated. Re-synced the channel on Studio, then re-published. I then tried to do a refresh of the channel on Kolibri. That didn’t result in a change. So, I deleted the channel on Kolibri and re-imported. Still no change testing from my MacBook with Safari. The videos still do not play.

I tested on this channel: https://studio.learningequality.org/en/channels/1e76871f1026447d812bfaaede867067/#/86927dd8fd3249c282d30fd66c0ce7ea

I imported that specific channel and verified that all videos are using codecs that should now work. Although, while one potential issue is resolved, I’m seeing the same error while attempting to play the video in Kolibri on a Mac. I’m not an Apple user so I had to use our testing tool, but good news is I’ve reproduced your issue using Kolibri 0.15.

I’ve also found a strange workaround that may work. When you open a video that fails to play, if you refresh once or twice, the video may become playable. This worked for me on a Mac, but I’m unsure about iOS devices.

Either way, I do now have some logs and I’ve filed an issue for you.


Refreshing numerous times in both iOS device and Mac did not get the video to play for me.

One question: with this particular problem, do you think the channels on Studio will need to be refreshed again and then re-downloaded to Kolibri, or the fix will be taken care of in an update of Kolibri?

Also, would you suggest I re-sync all the Khan content and re-import just to be sure I have the most current video/audio content that should work once there is a fix?

Also, would you suggest I re-sync all the Khan content and re-import just to be sure I have the most current video/audio content that should work once there is a fix?

Yes, I did detect some audio codecs in your channels that aren’t likely to work, which also appears to be resolved in the source Khan channels, so I do recommend performing the sync of file resources for all of your channels. That will require republishing the channels and re-importing them into Kolibri.

or the fix will be taken care of in an update of Kolibri?

Yes, the additional issue within Kolibri that we’re fixing will be taken care of in an update. By updating your channels with the most current video/audio and re-importing into Kolibri, you’ll then only need to update Kolibri once the fix is released.

Hi Blaine. Small update: I just added some additional channels from Studio. These were direct downloads of the entire channel with no curation. The two English language channels “English with Hello” and “Espresso English.” Both are YouTube origin video content channels. The content in them suffers from the same problem on iOS and Mac OS Safari (thus the Apple Web Kit) as the videos in Khan content. These did work before 0.15.

Any idea when an update to fix this bug might come?

Thanks in advance.

Hi @cjackson,

We just released a new 0.15.1 beta yesterday. It contains the fix for the issue you experienced playing videos on Safari. I’ve confirmed that I’m unable to reproduce the issue with one of your channels.

The 0.15.1 final release should be coming within the next couple weeks.


@blaine : I have a secondary Kolibri installation where I’d like to install the beta. It is the 0.15 version. How can I install the beta there to test out this and the other fixes? I tried this AM, but it didn’t work.

@cjackson You encountered an issue regarding installation of the beta version? If there’s a new or different issue from the this original issue, I suggest creating a new thread with the instance’s technical details and Kolibri logs.