Missing Images, Graphs, Questions

Dear all,

I find that my when making my way through Khan Academy questions, some are missing, or the accompanying image file/graph is missing, making it impossible to answer the question. See examples attached.

Sometimes the entire question is not available and instead I get a message “This question cannot be loaded” (paraphrased, as I am on another computer at the moment and have not got an available screen shot.

Please advise.

Hi -

We’ve recently published a new version (14) of the KA channel.

What version are you on? If your current version is lower than 14, would you mind updating and checking if the problem still persists?

thank you!

Thank you for the response. How does the update work, what do I need to do?

Kind regards,

Follow these instructions to update a channel, it’s a similar process as for importing a new one, but should go a lot faster.

1 Like

I have updated my KA Lite content as you mentioned here, however the Early Math lessons that do not present fully are still a problem. These are the Add/Subtract within 5 and Add/Subtract within 20. These particular exercises call for an expression made up of large colored numbers. All that is shows up is the empty answer square, but no expression. All the other pieces of the page show up. This problem is happening on iPad 2s that we have (many of them). However, this problem does not happen when connecting directly to Khan Academy online. This problem does exist on KA Lite 17.5. I even downgraded our KA Lite to v16 to see if that would resolve the problem, but it did not.

We would very much like for these exercises to work without having to change out our hardware to make it work. Any idea what can be done to fix this?

Thanks, will give that a go!

Hi @cjackson - sorry that you’re still having problems.

This problem is happening on iPad 2s that we have (many of them). However, this problem does not happen when connecting directly to Khan Academy online

What browser are you using on the iPad? Would you mind quickly checking if the problem occurs on any other device, or using Chrome if you’re currently using Safari? (Currently Kolibri does not support safari).

If the issue is happening with other devices/browsers, I’ll bring this to the attention of our content team.

thank you!

PS - QA on Khan Academy content has been challenging for us because the channel is so large. We’re currently exploring new processes to catch these issues earlier.

Devon:Thank you for replying to my query. This has been an ongoing issue and since we have 18 iPad2s here with us as our platform for using Kolibri and KA Lite, we’re kind of hardware stuck. I’ll give you all the details and what I’ve seen:

iPad2s: running last supported iOS 9.5.3. Have tried last supported version of Firefox (8.3 (5826), as well as last supported version of Chrome (63.0.3239.73) and MS Edge. Same problem across all of these browsers. Safari won’t load Kolibri because is not supported.

I did more testing yesterday. iPad Air 2, both running latest versions of iOS and the browsers - all work fine. Also, KA content works fine on Mac OS Safari, Chrome, Firefox, etc. I don’t have an Android-based device to test. I have tested with my MacBook Pro and a Win10 laptop. No problems with content delivery on these.

So, the problem seems to be limited to our iPad2s. I’ve found that the Early Math content we are working with proves to be hit and miss, particularly with exercises with graphics and large colored text. I’ve seen that it is showing up throughout all the early math exercises where graphics sometimes load, and often don’t.

I have seen this is the case with both the updated KA Lite content inside Kolibri and the current version of KA Lite. Yet, all of the same content coming directly from Khan online works without a problem.

So, could this be an incompatibility of Nginx and the version of iOS on these older iPads? I thought about trying the Apache-based install of KA Lite as described on the installation options to see if that could make a difference, but that would not solve the Kolibri issue. I’m really hoping there can be a fix for this as this is making our plans to implement difficult to realize w/o having to look at a major hardware purchase expense that is not in our budget.

thanks for your help!


I just found out form kollivier that all browsers on iOS make use of Apples internal browser. Thus, the issue for the reason(s) why we have the content problems lies somewhere in an incompatibility of the KA Lite content or the Nginx web content delivery system and the underlying browser system.

Just to be clear, when you say “KA Lite content”, I assume you mean “Khan Academy content”? (KA Lite is our older software and should be unrelated, unless you’re running that in parallel.)

If you suspect the Nginx config might be an issue, you can prove or disprove that by accessing kolibri directly it its port rather than going through Nginx

I’m not sure how this is done. We currently access Kolibri via port 8080. Is there another port I could use? This is what I get back from Kolibri status:

kolibri status
WARNING:root:No C Extensions available for this platform.

INFO Running Kolibri with the following settings: kolibri.deployment.default.settings.base
INFO:kolibri.core.apps:Running Kolibri with the following settings: kolibri.deployment.default.settings.base
OK, running (0)
Kolibri running on:

Yes, I mean the Khan Academy content available thru the Kolibri channels. However, the exact same problem exists with the same Khan content in the KA Lite implementation, so it is definitely an issue/problem with more than just Kolibri.

Just some additional info. Following on your idea to access Khan content directly rather than through Nginx, I decided to look at the options available with our KA Lite installation. Here is the status report from “kalite status:”

kalite status
OK, running (0)
KA Lite running on:

KA Lite configured behind another server, primary addresses are:

So, I accessed Khan content thru both ports and the same problem exists. I’m attaching a picture of an example content page in KA Lite, but it is the exact same problem in Kolibri, too. As you can see, everything displays except the exercise content. In this case, an addition problem should display with HTML formatting as a blue/HUGE… In other cases, the graphics don’t load.


To check if it is a browser issue and if the client can be put online: On that same client, does everything work on http://demo.learningequality.org/ ? And http://kolibridemo.learningequality.org ?

Do you know how to open up a debug dialog in the affected browser to check for JavaScript errors or network errors?

One note - looks like the affected exercises are not images, but MathJAX-related. This makes me start to believe it’s not nginx.

However to try bypassing nginx, check your config file and look for the upstream port. Then point your browser to that port instead. (Maybe 8081? Not sure without knowing your config)

I was able to get into the Kolibri demo site. Did some searching to find an early math exercise that i know is a problem on our installation. I finally found one in the Khan Spanish channel. Looked under Sumas y restas con numeros del 1 al 20. The exact same problem occurs with these exercices. All the parts of the page of the Kolibri framework show up, but the exercise content area is blank except for the answer entry box.

Again, this is on an iPad2 iOS 9.5.3 (last supported version) with Firefox version 8.3 (5826) (last supported version. Same thing happens across the other browsers I’ve tried on the iPad2: Chrome and Edge. Does not happen on an iPad Air 2 with iOS 12.1, Firefox 14 (12646).

I do not know how to do debug on an iOS device.

You idea about MathJAX made me look it up online. It supposedly supports the browser version I’m using. They suggested checking their web site to test if it is working and I did that. As far as I can tell, the MathJAX content is working.

An example of the exercises that don’t work is from Adding within 5. The HTML content of that exercise is: $\Huge{{?} = \blue{1} + \green{1}}$. This comes from the context link in CrowdIn as follows: https://www.khanacademy.org/translations/edit/redirect/e/addition_1?lang=xf30a491a85d150ec#en-pt


Do you think there is any chance this issue can be resolved? Devon thinks it has to do with an issue with MathJAX. We really hope to have this up and running by early January if at all possible, but if the Khan content can’t display correctly on the hardware we currently have to work with, we are kind of stuck.


Devon: haven’t heard any more about this issue. I did some looking at the MathJAX demo site again and the above argument I referenced from the Adding w/in 5 exercies does not render correctly even on a computer that has no problem with the KA content on Kolibri. I just copied string above and pasted into the live demo window. So, there’ something I don’t understand, etc.

However, my bigger question is whether this issue can be addressed/fixed, or not because our literacy workshops start the 2nd week of January and we hope to have this working at that time. The only hardware we have to work with are iPad2s, and it seems the early math content relies on these types of exercises across a broad number of the topics. That kind of shoots us in the foot, if you can imagine!

Any thoughts or is there anyone else I can be connected with in LE to work this through?

Thanks in advance for your help.