Kolibri 0.12 African Storybook ePub content won't load

@lingyi @devon @radina-matic I just upgraded to v. 0.12 because I wanted to regain the ability to view ePub files in full screen such as those found in African Storybook Chanel, as well as full-screen video on our iPad 2s. The upgrade went smoothly with no errors noted. Like the improvements thus far.

However, the ASb content will no longer load. The window with the Kolibri hummingbird shows up, but the content never loads. I have tested this on iPad2, iPhone SE, MacBook Pro and Windows 10. Has been tested in Safari on all these units as well as Chrome and Firefox. Same behavior. See picture below:

In addition, I checked to see if there was an update to the ASb channel, but that is not the case. I then downloaded an additional title to test to see that would make it work. It did not. Finally, I have verified that video content from KA English and Hello Channel English load and full screen works.

Thanks for your efforts at making Kolibri better!

Hi @cjackson! Sorry this has messed up the Epub rendering, we hadn’t come across any issues in testing, but I am seeing some issues with African storybook on the demo server: https://kolibridemo.learningequality.org/learn/#/topics/c/e4f10b047a515430a59aca4410153253 - not quite replicating the permanent loading state though, which is even more severe.

If you are able to access on a desktop machine, would you be able to access the developer tools and look at the Javascript console, and copy any errors displayed there to help diagnose this?

Apologies for this disruption to your work!

Kind Regards,


@richard: I will happily do that, but I need some instructions as I’ve not done that before. Or, I can send via email a way for you to directly access our Kolibri server. I have done this with Lingyi. Let me know what you prefer.

Also, I have discovered another problem which appears to be limited to the iPad2s we have. Prior to the update, we had a shortcut icon set up to take the users to http://kolibri.jv:8080. I have a firewall/router that locally resolves the name address to the IP address. This worked with no problem. Now, it does not work. Previously, what would happen is Kolibri would resolve to http://kolibri.jv:8080/user/#/signin automatically. Now, the page resolves to the flying Kolibri icon and does not go to the signin page. What is more strange, is when I put in the full address http://kolibri.jv:8080/user/#/signin, it still doesn’t resolve and load correctly. I have cleared the cache on the iPads in question, but still no change. Changing the alpha address to the numeric IP address also does not resolve the problem.

What gets the signin page to show requires manually changing the address from http://kolibri.jv:8080/user/#/signin to http://kolibri.jv:8080/user, then it resolves again to http://kolibri.jv:8080/user/#/signin and loads the login, but does not retain the previously selected language option. I changed the shortcut to http://kolibri.jv:8080/user, but this does not work for some reason. Instead, again, I have to manually edit down the address that it resolves to (http://kolibri.jv:8080/user/#/signin), down again to http://kolibri.jv:8080/user. Then it resolves again again to the same address (http://kolibri.jv:8080/user/#/signin) and shows the login page always in English.

Sorry for the lengthy explanation. I’ve tried to capture what I have observed thus far.

Direct access might be simpler, you can reach me at richard at learningequality.org.