KALite Login button takes a long time to activate with many users

I loaded over 18,000 users in my KALite database and now the login button stays grayed out for up to 2 minutes, then turns full red and you are able to login. I am guessing it is prefetching all of the accounts. IS it possible to disable this prefetch or add an index to the table to speed this up?

Thank you

@cdouglas Are you using simplified login? It was because of this PR, it fetches all users from the database. I think disabling simplified login would work.

In your ~/.kalite/settings.py, try adding SIMPLIFIED_LOGIN = False

It’s disabled by default

That’s exactly what I found last week, that when you turn on simplified login, it turns on autocomplete. But I need simplified login, so I edited the code to not use autocomplete when you turn on simplified login.


Hi @cdouglas

We originally had a limit of 1,000 users for simplified login to work. I guess it was a strange way of solving the fundamental issue, that a list of all usernames seems to be transmitted to the client side :blush:

You can see more background here: https://github.com/learningequality/ka-lite/pull/5527

Please feel free to contribute a solution to this or perhaps get in touch with Edulution about it, since they would seem to share this interest.