After upgrade to v.11 create an account (allow learners to create account) not working

After upgrading to v.11 a new user is not able to successfully complete a User Sign Up from the CREATE AN ACCOUNT button from Sign-in page. I tested server before upgrade to v.11 and the User Sign Up worked

I have same exact issue with another server that was new installation with v.11

On both servers, The User Sign up page appears after clicking on CREATE AN ACCOUNT button from Sign In screen. After completing the Create an account form and pressing FINISH nothing happens.

Any ideas or advice?

Hi @mrdavidhaag,

Could you please upload the kolibri log file ~/.kolibri/kolibri.log here so we can see what might have gone wrong? Thank you so much!

Thank you for the prompt response. Happy New Year.
The file is here

I noticed the kolibri.log file is dated in Nov. The upgrade took place on 26 Dec. After the upgrade, I did use sqlite3 to fix database because the server failed to start. But after repairing db the server seems normal other than create new user not finishing.

Hi @mrdavidhaag,

It looks like your upgraded 0.11 kolibri might be installed under another user. Did you upgrade kolibri using our Debian installer? If so, could you please show me the result of cat /etc/kolibri/username? Thank you, and happy new year!

root@KOLBRI-UBN-16:~# cat /etc/kolibri/username

I believe I used apt-get upgrade

Thank you so much for the quick reply! Would you be able to check if /var/admin/.kolibri/kolibri.log file exist? If so, could you please upload it here? My guess is that admin might be the user that’s running current kolibri.

yes, the file does exist and is here
I renamed it adminkolibri.log
I am using Drive because I was not able to upload log file (only image files). Is there a way to upload log files here on the support site

Hi @mrdavidhaag,

I’m sorry that uploading log files on this site is not supported.
I’m wondering if it’s possible that the username for the account you are trying to create has existed on the server.

Could you please inspect the page after you see nothing happens in the sign up page?
To inspect the page, please right click on the page and select Inspect or Inspect Element. After that, click on the Console tab. Do you see any errors there after you complete the Create An Account form and press FINISH? Thank you!

No problem, will continue to use Drive
there does seem to be error in Console (I am using Chrome)
I cleared the console and opened the Create an account page and console was blank
then filled out the form and pressed Finish (nothing happened) and then console had error
I named the log file afterclearafterfinish and it is here

Hi Lingyi
I just finished a fresh install on VM in ProxmoxVE 5.2 with VM running Ubuntu 18.04.1 and Kolibri v.11

The same problem exists on the Create an account page. After completing the form and pressing Finish nothing happens, but this error appears in the Console window of Chrome found here

The Drive link is for the folder now. Chrome console error is newinstall-cons-error.log and I included the kolibri.log file for installation as newinstall-kol.log

Thank you for your work on this.

This option for new learners to create their own account is somewhat important for this installation. This Kolibri is open to the village via a non-revenue access portal of the Community Cellular LTE system. A villager with smartphone and LTE service is able to access the Kolibri server without using any of their airtime credits or quota. We want to be able to track the usage of this non-revenue service, hence the need for new learners to create their own account.

Hi @mrdavidhaag,

thank you so much for the information! It’s really helpful to us.
We are still unsure about what caused this issue but have been actively looking into it. I will try my best to update you as soon as we have some progress.

In case you are interested, we have a github issue for it:

OK, thank you for the positive action towards resolution. For now we can add users manually no problem.

Would you like me to add my findings and information on github?

Hi @mrdavidhaag,

thank you for your understanding!
Yes, it would be much appreciated if you could add any information on github when you have time.

Hi @mrdavidhaag,

We have figured out the bug in our code regarding this issue and have a fix for it. The fix goes into kolibri 0.11.1, which we are planning to release this Friday, January 11th.

If you would like to be able to create an account before our 0.11.1 release, we suggest you allow the guest access in the facility settings. Once you allow the guest to access the content, you should be able to create accounts for learners in your current 0.11.0 kolibri instance. To do so, please try the following steps:

  1. Log into your facility admin account
  2. Go to Facility --> Settings
  3. Check the setting Allow users to access content without signing in
  4. Click Save Changes

After this, you should be able to create accounts for learners in 0.11.0. If you do not want to have guests access the content but still need to create account, I’m sorry that you would have to wait till this Friday for 0.11.1 to do so.
Thank you so much for supporting our work!

Thank you. I followed the fix on github and appreciate the skill of LE team. Well done.

I already tried the fix and yes, it positively fixes the problem.

I will try the 0.11.1 version as soon as it is available.

Thanks again for your alls hard work and efforts in helping others.