[RESOLVED] What am I missing? (Error message)

Operating System (e.g. Windows, MacOS, Linux):
Windows 10
Browser (e.g. Chrome, Firefox, Safari):
Channel (Name of the channel you were working on):
Description of problem:
Studio shows error message, with no description.

With everything filled out, I still get an error message:

Questions subpage, filled out too:

Related page filled out too:

I am curious why I am getting an error, the error is not specified, anywhere, and everything is filled out.
Also, why is the indicator green, when at the main screen, like there is no issue?

Note, clicking on “Edit” shows the red error:

Clicking finish after this presents the same message:

It’s most likely the Mastery Model for the exercise, or the license. Sorry, we realize that it is hard to pinpoint why a resource is incomplete at the moment, and are working on some user experience updates to try to make this better.

Looking through all your screenshots though - that does not seem to be the case. Could you DM me the direct link to this resource in Studio, so I can investigate further?

1 Like

Message sent, thank you @richard !

Hi Sam,

I really can’t see anything you are missing, this seems like a bug. I’ve filed a report for it on our issue tracker.

One question - if you publish the channel, does the exercise get published with it?

Kind Regards,

I have not tried publishing it. I cannot lie. I am kind of nervous about doing that. The last time I did it, I had to have backend support via the forums to get it to stop. I will try it Monday though, that way if it does freak out and lock up like last time, I can contact you here, and I don’t have to wait over the weekend to continue working on the channel. I will update you on Monday when I publish @richard. Thank you again for your prompt responses and support.

Hi Sam,

Sorry that you’ve had multiple issues here - the publishing issue you experienced has not been a frequent occurrence, but has definitely happened more than once. Because of that it has been harder to isolate the cause, but we are doing work to add better audit logging to better understand how the issue occurs when it does happen.

Kind Regards,

Multiple issues, that were solved. I should have emphasized that latter point. I very much appreciate the assistance that you guys give. No need to explain. I will try to publish Monday, and let you know how it goes.

@richard Okay, so as promised, I published. No issues, page that was throwing errors, published fine on local host.