Import multiple users from CSV

If you have a specific technical inquiry, construct your post with the following:


I have a CSV file with usernames that I want to import into kolibri. When I run - C:\Program Files (x86)\Kolibri> kolibri manage importusers C:\Users\Fundi\Documents\KolibriFile.csv as indicated on the manual, then what it does is odd, because it opens Kolibri on the browser and doesn’t do anything relating to importing the users. The users are not added and Kolibri doesnt through any error.

This is the screen to goes to

Initially i tried running the commands from the command line as indicated on the manual but it doesnt seem happy with the Kolibri command

Technical details

  • Version: 0.12.7
  • OS: Windows-8-6.2.9200
  • Installer: Windows
  • Server: Kolibri internal server
  • Database: C:\Users\Fundi.kolibri\db.sqlite3
  • Device name: Fundi
  • Free disk space: 44 GB
  • Server time: Wed Aug 14 2019 20:29:36 GMT+0300 (East Africa Time)
  • Server timezone: Africa/Nairobi

Hi @maxwellfundi, could you try something for me? On the windows command prompt, could you type kolibri --help? (two dashes before the help). I’m wondering if you get an output like this (or if it just opens Kolibri in the browser like before).

C:/> kolibri --help


Supported by Foundation for Learning Equality

  kolibri start [--foreground] [--port=<port>] [options]
  kolibri stop [options]
  kolibri restart [options]
  kolibri status [options]
  kolibri shell [options]
  kolibri services [--foreground] [options]
  kolibri manage COMMAND [DJANGO_OPTIONS ...]
  kolibri manage COMMAND [options] [-- DJANGO_OPTIONS ...]
  kolibri diagnose [options]
  kolibri plugin [options] PLUGIN (enable | disable)
  kolibri language setdefault <langcode>
  kolibri plugin --list
  kolibri -h | --help

@jonathan Doesnt seem to do anything still- Are there any environment variables i need to set before hand?

Yes, it looks like kolibri isn’t on your system’s PATH (so you can call programs without providing their exact location). Could you confirm that you have Kolibri 0.12.7 installed, since that installer is supposed to automatically set up the PATH for you.

Otherwise, you would need to add kolibri.exe to your PATH environment variable yourself. I’m not familiar with Kolibri on windows, so I’m not sure where that is on the file system. I’m asking the team right now. The kolibri executable should be located at C:/Python34/scripts/kolibri

@jonathan I have actually figured out why this was not working. I have 0.12.7 installed and I checked my Path environment and it seems its on the C:\Python34\Scripts so after running --help here it seems to do something i would expect.

So let me now see what happens when I do the other things

@jonathan many thanks for your help on this- Now I have manged to run the command from the

and created all the users i needed.

@laura I think adding this to the documentation would greatly help other people out there who might have similar issue.

1 Like

I’m glad you figured it out @maxwellfundi! It does look like a problem that you weren’t able to use kolibri manage importusers outside of C:/Python34/scripts, since kolibri should be added to the PATH as of version 0.12.7. We’ll look into it.

Perfect thanks @jonathan

Seems it adds the environment variable and its actually pointing the C:/Python34/scripts

Oh interesting. Could you look at the “Path” variable 3 rows below and see if that folder appears there as well?

@jonathan the %KOLIBRI_SCRIPT_DIR% does not appear in the Path. This is from Kolibri 0.13.1 on Windows 10.

So this needs a fix as well as needs to be documented. @laura

I believe that environment variable should be set during the installation wizard at this point in the code. @shrenik if you’re seeing otherwise, would you mind filing an issue in the Windows installer repo?

Thank you!

Thanks @devon