Apt-get install on Chomebook Linux

I have a chromebook that I’ve enabled Linux on by switching to the beta channel and enabling Linux in settings within ChromeOS. I was able to install libreoffice with sudo apt-get install libreoffice.

When I run this command: sudo add-apt-repository ppa:learningequality/kolibri

I get this error:

Exception in thread Thread-1:
Traceback (most recent call last):
File “/usr/lib/python3.5/threading.py”, line 914, in _bootstrap_inner
self.run()
File “/usr/lib/python3.5/threading.py”, line 862, in run
self._target(*self._args, **self._kwargs)
File “/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py”, line 688, in addkey_func
func(**kwargs)
File “/usr/lib/python3/dist-packages/softwareproperties/ppa.py”, line 386, in add_key
return apsk.add_ppa_signing_key()
File “/usr/lib/python3/dist-packages/softwareproperties/ppa.py”, line 252, in add_ppa_signing_key
tmp_keyring, tmp_secret_keyring, signing_key_fingerprint, tmp_keyring_dir):
File “/usr/lib/python3/dist-packages/softwareproperties/ppa.py”, line 181, in _recv_key
“–recv”, signing_key_fingerprint,
File “/usr/lib/python3.5/subprocess.py”, line 247, in call
with Popen(*popenargs, **kwargs) as p:
File “/usr/lib/python3.5/subprocess.py”, line 676, in init
restore_signals, start_new_session)
File “/usr/lib/python3.5/subprocess.py”, line 1282, in _execute_child
raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] No such file or directory: ‘gpg’

And then when I try to install Kolibri, I get this error:
E: Unable to locate package kolibri

What am I doing wrong?

Hi educell, it looks like a problem in your Linux settings. The package does not even begin to install. I don’t know if ppa can be used in a chromebook. In this particular case, according to your error traceback is clear your Linux installation is not complete to use add-apt-repository because it complains of a missing package, gpg. This thread https://www.reddit.com/r/Crostini/comments/91a4i4/trying_to_add_repo/ seems to provide a solution.

If that solution fails, you can download the package and install it manually, without apt, doing sudo dpkg -i kolibri_0.11.0-0ubuntu1_all.deb

Hope it helps

Thanks for the response.

So I did

sudo apt-get install gpg

and tried to add the ppa again. This time I get this error:

Err:10 http://ppa.launchpad.net/learningequality/kolibri/ubuntu disco/main amd64 Packages
404 Not Found
Ign:12 http://ppa.launchpad.net/learningequality/kolibri/ubuntu disco/main Translation-en_US
Ign:13 http://ppa.launchpad.net/learningequality/kolibri/ubuntu disco/main Translation-en
Reading package lists… Done
W: The repository ‘http://ppa.launchpad.net/learningequality/kolibri/ubuntu disco Release’ does not have a Release file.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/learningequality/kolibri/ubuntu/dists/disco/main/binary-amd64/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Then if I try to install Kolibri I get the same error as before.

So based on this forum, I think I need to find the “gpg keys” for the Kolibri ppa…but my googling isn’t turning anything up.

Any ideas?

Thanks.

Well, the problem now it’s totally different, apt seems to work now. You could skip the gpg keys problem accepting the package, but… the problem is the package does not exist for the ‘disco’ version of ubuntu.
Your system says you are using such version, and it just does not exist.
I have never used a chromebook but it’s clear the Linux setup is not very clean.
You can solve it editing the file in your chromebook (maybe it’s in /etc/apt/sources.list.d ) changing the word disco by stable .
This is a problem you are going to have with any ppa you want to install, so the long term solution is fixing your system to avoid the use of the word ‘disco’ as a release name.

I can install Kolibri from the .deb package and it will run on that machine, but is not accessible from other devices on the network. Maybe because the Linux environment on a Chromebook is a virtual machine…? I know Kolibri has plans to eventually run on a Chromebook, but I thought that with the new Linux feature on Chromebooks I could get it working now.

I’m going to keep running on the chromebook I converted to a Linux machine for now. It would be really convenient in the future if Kolibri could install and run in the linux environment that comes with ChromeOS if it can’t run on ChromeOS itself.

With the ChromeOS Linux environment, I can run the other essential offline programs like libreoffice, so besides Kolibri, my teachers can use stock chromebooks and I don’t have to worry about them exiting developer mode or me having to totally convert to a linux machine. Implementation would be much simpler if Kolibri would work on the Chromebook.

Yes, it would be nice to have that support too.
I think your problem must be some kind of firewall the chromebook has set, so it does not allow external access to the Linux part.
If you link here the tutorial or instructions you followed to install it I can take a look, just in case.
Sorry for not being able to be more helpful, but without having access to that kind of device it’s quite difficult

I never found a really good tutorial, I had to use pieces from several, but here some links I used:



What I actually did:

  1. switch to beta channel
  2. enable the crostini experimental flag
  3. Turn on Linux in main settings

After that I could install libreoffice with sudo apt-get install libreoffice.

In order to install the .deb Kolibri package, I had to move the package to the “Linux folder” on the chromebook.

I’m currently running Kolibri on a chromebook that I modified the firmware using this script and then installed GalliumOS on.

Thanks for your help.

1 Like

Hi @educell

Indeed, using a PPA on ChromeOS will give you some general issues as @jredrejo mentions. It’s not the required way, though. It’s the suggested way for Ubuntu/Debian systems.

I would recommend to use the RPi installation instructions instead, thereby navigating entirely clear of the PPA issues…

  1. Remove your current PPA by doing sudo rm /etc/apt/sources.list.d/learningequality*
  2. Go to manual RPi setup and follow the instructions there.

The RPi instructions also mention to install some cffi packages, and I think that could be relevant for your ChromeOS, too.