[RESOLVED] Ubuntu can't find kolibri ppa

I am installing kolibri server on Ubuntu 23.10, I am following the installation commands from the official page: Download Kolibri | Learning Equality

sudo apt-get install software-properties-common
sudo add-apt-repository ppa:learningequality/kolibri
sudo apt-get update
sudo apt-get install kolibri

However, when running the second command it shows me the following error:

Does anyone have any idea how I can fix it?

  • Kolibri version: 0.15.12
  • Operating system: Ubuntu 23.10 x64
  • Browser: Brave

hi @25_tanisha
this error message is due to the fact the Learning Equality repository for the Ubuntu 23.10 version does not exist. Ubuntu releases a new version every 6 months and they are discarded as fast as they are released, excepting the LTS (long term support versions). A new LTS release will happen next April.

You can safely edit your configuration to install it from a previous ubuntu version. In order to do this, start the software updates application in ubuntu (if you don’t find it in the apps menu you can launch it using alt-f2 and entering software-properties-gtk)

Then, click to edit the learningequality line and change mantic by an older ubuntu distribution, as jammy.
After that you can either install kolibri from this same app, or from a terminal with
apt update
apt install kolibri

In case this process is impossible or too hard for you, a release for mantic can be ready in one or two day. There were no plans to do a new release until the next Ubuntu version in April, but it’s doable for Ubuntu 23.10 if you need it.


Thanks for the answer and clarification.
I tried to install the jammy version, I have no problems with the ppa, now when I run the command:
sudo apt-get install kolibri
after it asks me for the username it throws me a new error

Thank you very much for your support!

oh, I see , that’s because you’re trying to install it after you’ve impersonated as a root user and can’t find a system user to run kolibri.
Please, don’t run it from the root user and it should work fine.

Thank you very much, I managed to install it.

1 Like