[RESOLVED] How to install SSL certificate on Kolibri server

Hello, I have installed Kolibri on a linux server which is connected to the internet.
The Kolibri instance can be reached by calling it with its IP address + 8080
I’m trying to add an SSL certificate, but don’t know if I need to install nginx before or after Kolibri.
Could not find any help about this on the documentation.
Please help with detailed procedure in command line.

Hi @Antonio_Herrera,

Thank you for your interest in Kolibri!

You’re correct that in order to use an SSL certificate with Kolibri, you need to put nginx in front of Kolibri. This approach is commonly referred to as a ‘reverse proxy’, and ‘SSL termination’ with the SSL certificate in the mix. Our kolibri-server debian package, which can be installed using these instructions, installs and configures nginx with a reverse proxy to Kolibri. You may then edit the configuration to use an SSL certificate.


Thank you, I really appreciate your help !!

1 Like

One quick question:

Should we install the kolibri-server ON TOP of Kolibri?

Or does kolibri-server include the Kolibri engine?

We have tried to install kolibri-server from the repository but it did not work.

Where can we download kolibri-server?

hello @Antonio_Herrera

kolibri-server is a Debian package that:

  • installs kolibri
  • install nginx & uwsgi
  • configures nginx, kolibri & uwsgi to work togethet

So, doing apt install kolibri-server will drag all its dependencies, you don’t need to install them separately.

As Blaine mentioned in a previous comment in this thread, if you want to use https you have to add the needed ssl configurations to nginx. There’s nothing special in kolibri-server, it just adds some configs to these known applications that are good to go in one step. You’ll need someone with sysadmin skills if you want to customize it.

José L.

I tried that but I got the following which seems like there is an issue:

Kolibri is an offline app and platform for universal education.

The latest documentation is available here: http://kolibri.readthedocs.io/

Retrieve and Distribute Open Educational Resources (OER) from online resources or from device to device. Resources are shared as ‘channels’, amongst which can be found Khan Academy, PhET and CK-12. To find more channels and create your own, please visit our website for sharing and editing channels: http://studio.learningequality.org/

Given that Kolibri is intended for offline environments, the package is designed to be portable without the need to download further dependencies.

Adding the PPA as an online source:

sudo add-apt-repository ppa:learningequality/kolibri
sudo apt-get update
sudo apt-get install kolibri

Downloading portable .deb files:

  1. Go to “View package details”
  2. Click on the latest package. It doesn’t matter which one, all binaries
    are the same, regardless of your architecture or Ubuntu/Debian version.
  3. Scroll down to “Package files”.
  4. Fetch the relevant .deb file.
    More info: Kolibri : “Learning Equality” team
    Adding repository.
    Press [ENTER] to continue or Ctrl-c to cancel.
    Hit:1 Index of /ubuntu mantic-security InRelease
    Hit:2 Index of /ubuntu/ mantic InRelease
    Get:3 Index of /ubuntu/ mantic-updates InRelease [109 kB]
    Hit:4 https://repos-droplet.digitalocean.com/apt/droplet-agent main InRelease
    Hit:5 Index of /ubuntu/ mantic-backports InRelease
    Ign:6 Index of /learningequality/kolibri/ubuntu mantic InRelease
    Err:7 Index of /learningequality/kolibri/ubuntu mantic Release
    404 Not Found [IP: 443]
    Reading package lists… Done
    E: The repository ‘Index of /learningequality/kolibri/ubuntu mantic Release’ does not have a Release file.
    N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

NEW UPDATE: we discovered that the issue was our version of Ubuntu.
While writing this message, the installation process seems to be going through successfully.


Thanks for the feedback. Marking this as resolved!