Random Server Port in OSX Kolibri

I am just hoping to do some local testing on content structures with Kolibri (and brand new to it). I hoped to use one of my OSX laptops as a server, but for both of them, I never see content on the default 8080 port, each time I start the app, I get a random 5 digit port.

Likely I have overlooked something simple!


Here is the device info on one machine:

I can access the server using this URL, but the port changes each time I restart the app.

I can confirm its listening to the port using command line:

sudo lsof -i -P | grep LISTEN | grep :$PORT

And I have tried setting a port in .kolibri/options.ini trying both 8080 and something long like 55555

Technical details

  • Kolibri version: 0.15.12
  • Operating system OSX 12.6.6 (Monterey) and an older laptop machine running 11.7.6 (Big Sur)
  • Browser: Any

Thanks for any help.

Hi @cogdog,

Because the primary target of the Mac OSX app is as an app rather than a server, this is why it does this behaviour. Your instinct to set it via the options.ini is very reasonable, but the OSX app actually bypasses this setting (this is something we can rectify in future releases).

For now, the best way to handle this would be to install kolibri via pip pip install kolibri and to run it from the command line to have more finegrained control. Alternatively, you can also use the pex file found on our downloads page.

I have logged the issue you are seeing with it ignoring the options.ini here: App ignores options.ini port settings · Issue #112 · learningequality/kolibri-app · GitHub

Kind Regards,

Many thanks @richard for the quick response. I will give the python route a try. The OSX app does serve content fine, just it’s over a random port, and I am merely trying to try some different ways of packaging our learning content. Since I am the only user, the port number does not matter.