Preseus Excersise Rendering issue in Kolibri

I had created Perseus exercise as follows

Step 1 : Create Exercise -SUCCESS
from the URL

Step 2 : check Exercise preview from rendered view -SUCCESS
the perseus exercises is rendering fine the rendered view as below

Step-3 : Created Channel with Exercise and HOST channel using Ricecooker - SUCCESS
used ricecooker to host in Kolibri studio portal
Step-4 ; Download published Channel from Kolibri studio to Local console - SUCCESS

Step-5 : Invoke Local channel - SUCESS

Step-6 : Access Perseus exercise in Local Kolibri portal ( - FAILED

the Perseus exercise is not rendering as shown the and show mnemonic codes as below

Action Taken

  1. Installed kolibri-exercise-perseus-plugin 1.0.5 from
  2. Tried to enable as per given Procedure but Not sure the Plugin in active

Anyone did preseus exercise and succeeded …?
Please Help


Greetings Dhana,

It seems that the Kolibri perseus renderer is missing some assets that are preventing the expressions from being rendered correctly. To further debug this, can you:

  1. Let us know the browser, browser version, and operating system you are using.

  2. Paste the JSON of the exercise you created by toggling Developer JSON Mode. Below is a gif demoing how to do so.


HI Chrisitan,
Thank you for your reply
our environment is as below
Windows 10 professional, and had tried with Microsoft Edge 42.17134.1.0, Google Chrome version 68.0.3440.84 (Official Build) (64-bit) and Firefox 61.0.1 (64 bit)

Yes, I had copied the JSON and using ricecooker to create perseus exercise and created channel as below
I had uploaded the Test Channel with Tag 1a774929b8f25d228afe61c1850e5bb9 available in Kolibriri studio to Download

If you have any other options, please let me know


Hi Christian,
Please download my Test Channel ID f58f121643545ae19d786ed1f6464b39

from kolibri studio and advise

Hi Dhana,

I replied to your comment on the sample-channels thread:

@christian: perseus renderer seems to be working fine, see
I’m guessing the old sample code in the ricecooker repo has some problem… I’ll need to check/update that when I come back to good internet.