kolibriCoreAppGlobal is not defined

Hi @marcellamaki @richard
When I took a clone am getting this error after installation when the project started ( kolibriCoreAppGlobal is not defined)
What I need to do for this

I tried, these steps

  1. Removed .kolibri folder and tried again
  2. I Took a new clone and also tried,
    but nothing is working

This sounds like you are cloning from github?

If so, please make sure to follow the Getting started steps for the development setup.

Thanks for the reply @richard
Sometimes it is working sometimes it’s not, is there any solution that I need to do for that
Can you please explain how this is occurring, it may help me

Hi Aswin,

@richard is pointing out that, from your description, you installed Kolibri using git/github. This is typically the way that a software developer installs the app, primarily for making modifications to the application.

When installing it in this manner, the parts of the Kolibri application accessed from the browser need to go through a “build” process to make them available. The error you described: kolibriCoreAppGlobal is not defined, is typically only seen when that process did not complete successfully.

Assuming that you installed via git, and that you do, in fact, intend to modify or make contributions to the application, please follow the instructions laid out in the link that Richard posted above.

If you do not need to make modifications, it would probably be better to install Kolibri using our premade installers/applications:
Install Kolibri — Kolibri User Guide

Otherwise, is there any other reason you installed via git and not via the premade installers/applications?