Import Facility from RACHEL

We are using the RACHEL server (smart box) in our school in South Sudan. We have successfully set up a facility on Kolibri and created our curriculum. It is all working well. Our goal now is to install Kolibri locally on two laptops and import the facility we set up originally on RACHEL. We will then send the two computers with two students who are temporarily moving to a different city so they can continue to progress in their own schoolwork while not at the school.

I have already downloaded and installed Kolibri on the laptop, but I am getting stuck in the initial setup. When attempting to import our facility, it says in the setup guide “Any device that has Kolibri running in the local network should appear in the Select network address window.” However, although the laptop is connected to RACHEL via the internet, it never “appears” automatically like it should:


I then try manually entering RACHEL’s IP address I found from clicking on RACHEL’s WiFi on the local computer as follows:

I am then allowed to click on this network and continue:

But in the last step, no facility show up for me to select and enter admin credentials (even though our facility is on RACHEL):

The user guide and troubleshooting document only say “Select facility” with no other information on what to try if no facilities show up. This makes me think my error is somewhere in the previous step (selecting the RACHEL network), since if it were truly connected to RACHEL, our facility would presumably be showing up automatically. Perhaps I am entering the incorrect IP address for RACHEL, or perhaps I need to be connected to RACHEL some other way than through a WiFi connection, or perhaps I have misunderstood some other requirement for this step.

Could you advise on how to get past this road block in setting up Kolibri? I have tried my own troubleshooting techniques and the tips on your website, but I think I have reached the end of what I know to try.

Thanks!

Hi @CCS, welcome!

I have a couple of clarifying questions.

However, although the laptop is connected to RACHEL via the internet, it never “appears” automatically like it should.

Do you mean that you’ve connected the laptop directly to a RACHEL WiFi hotspot? When connected in this way, are you able to access the RACHEL instance of Kolibri by manually navigating to http://10.10.10.143:8080 in a web browser from the laptop? That’s one way to check if the laptop is really able to communicate with Kolibri on the RACHEL.

By the way, to make sure you’ve got the right address, you can navigate to the Device > Info tab on the RACHEL Kolibri instance to double check. The RACHEL Kolibri instance’s IP address should show up in the Server URLs section as shown here.

That could be, but it’s also possible that due to firewall settings on the laptop or on the RACHEL device that they could be on the same local network but that automatic discovery still wouldn’t work. In that case, assuming the laptop and RACHEL were indeed connected, the steps you took of manually entering the address of Kolibri on the RACHEL should be a good workaround. (By the way, for automatic discovery to work, UDP port 5353 needs to be open on both devices, but this isn’t a requirement for manually added network addresses).

Lastly, can you share some information about which versions of Kolibri you have installed on the RACHEL and on the laptops?

I hope we can get this figured out!
Micah

Not sure if this is what’s going on in this case, but note that on a RACHEL I believe they have the port set to 9090, not 8080.

Yes, the laptop is directly connected to RACHEL via its WiFi hotspot. I can access RACHEL’s instance of Kolibri in a browser. However, I was indeed using the incorrect url previously, since the url that accesses RACHEL’s instance of Kolibri is http://10.10.10.10:9090. I have tried using that as the “full network address” rather than http://10.10.10.143:8080 like I was previously trying, but there are still no facilities showing up automatically.

I also tried to find the IP address through device->info like you suggested, but we have never been able to access that page on any of RACHEL’s chrome books or on a separate laptop. This is the error message we get every time we try to access that page:


I then tried using ipconfig in the Windows command prompt, but I’m not sure I’m able to fully interpret what it returned to be able to find the correct url:

In answer to your final question, Kolibri on RACHEL is v 0.9.2, and the Kolibri on the laptops is the latest version, 0.14.6.

Hello @CCS,

Wonderful, I’m excited to hear this! Please know that you are always welcome to post any questions or feedback you have here on the community forum.

This means that http://10.10.10.10:9090 is the correct address, however…

Well, that is the reason why it isn’t working. The required syncing features weren’t added to Kolibri until version 0.14. Unfortunately there isn’t any way to do the syncing without upgrading to version 0.14.x on the RACHEL device.

@jamalex and I each did a little digging to see how hard it’d be to do this upgrade, but so far haven’t found anything too useful yet. You might try posting on the RACHEL forum to see if anyone has tried this before, or if anybody over there has advice on how to proceed

Next week I’ll do some more research on this. If I find anything out I’ll be sure to share it here.

(By the way, if you do figure out how to upgrade and decide to try it, make sure that you back up your Kolibri before trying, in case anything goes wrong!)

Take care, and keep us posted,
Micah

I believe World Possible is working on a module for upgrading Kolibri in-place on RACHELs that have older versions. I’ll flag this thread for them so they can chime in when it’s ready.

Thank you for helping me pinpoint the problem. I will reach out to World Possible and the RACHEL forum to figure out how to update Kolibri on the server. Stay tuned.

We received some instructions from World Possible on upgrading to the latest Kolibri:

Please go to admin->Install tab. Search and select the “zz-kolibri-upgrade” module, then click the download button. The update will take ~3-5 minutes. You will get a stalled message (expected). Once the install has completed, zz-kolibri-upgrade will become listed as one of the installed modules. After the install, it is recommended that you reboot the device. At that point you may login to the kolibri module and note rev 0.14.6

1 Like