Cannot Import Facility - could not connect

Hi there,
We are very new to Kolibri and falling at the first hurdle - so please be patient!

My colleague and I are looking to start using Kolibri to understand how it works, and how it might be useful for delivering content across our schools networks in Uganda and Zambia. Both of us have managed to install Kolibri onto our Windows desktops.

My colleague set-up a new Facility - just to start using it and test things out.
When I boot up my Kolibri, I try to ‘Import Facility’ so that we’re both using the same one and playing in the same space. For ‘Enter Address’ we tried many things - inc. the ‘Server URL’ on her Device Info, her laptops IP address… and time and again I get the error:

‘Could not connect to this network address’.

We have tried turning off our Firewalls, as per the troubleshooting guidance. But to no avail.

Does anyone have any ideas? I’m sure it is something simple we are missing!

Technical details

  • Kolibri version - 0.14.0
  • Operating system - Windows 10 Home
  • Browser - Google Chrome 87.0.4280.88

Hi @emmatsu,

If my understanding is correct, you’re trying to connect with your colleague’s Kolibri facility on your own machine, so that you can interface with her instance’s resources. Is that correct?

If so, the best way to accomplish this would be to navigate to her Server URL from your internet browser, rather than from your Kolibri installation. Assuming you’re both on the same network, you should be able to connect as though you were accessing a website. She’ll have to give you admin-level permissions for you to have full access to all the settings in her Kolibri instance.

The “Import Facility” interface you’re interacting with is a peer-to-peer feature meant to manually sync “snapshots” of data between installations. This doesn’t sound like the feature you’re looking for at the moment.

That being said, the “Could not connect to this address” error is still concerning. If Firewalls are already disabled and you’re both on the same local network or intranet, you should be able to access each other’s instances at your respective addresses/ports.

Are you including the port information in the address as well? Typically, this would be annotated after a colon on the IP address. For example:

http://192.168.0.123:8080

8080 should be the default port if you installed via pip.

Thanks,
David

Thanks so much @david - this is immensely helpful! Clearly we’ve just misunderstood what the ‘importing’ does.

Your first point is correct - I just want to connect with her Kolibri facility so we can test setting it up and the functionality in the same instance.

We are not both on the same network - we work from home in completely different locations. Is it still possible to access the same instance via the Server URL? I tried navigating to it from my browser, but I just get a ‘the site can’t be reached’ - too long to respond:

Thanks,
Emmi

Kolibri is, “out of the box”, designed for communication over a shared network. Local Area Networks (LANs) are the easiest way to set that up.

If you’re both on separate networks, there are some options I can point you in the direction of:

  • Setting up a Virtual Machine on a cloud provider or other public-facing computer. Both of you then access that machine’s IP address.
  • Hosting the server from home and port forwarding from the public-facing router to your computer. Then connect via the public IP address (similar to the one above).
  • Simulate a shared network by setting up a VPN for both of you to connect to. You’ll then be accessing eachother’s instances via the shared network.

Unfortunately, all of these options require a certain degree of familiarity with computer networking, and support for those broader topics are outside the scope of our forum :frowning:

David

For initial testing, you can use ngrok to give Kolibri a temporary public URL that can be accessed from the internet.

Devon

Thank you @david and @devon - this was really useful for finding a way forward. We’ll have a think about the best way forward.

Thanks for taking the time to respond.