[RESOLVED] "sudo systemctl kolibri" stop Returns "Unknown operation Kolibri"


I have completed an install of Kolibri according to the instructions detailed at:


I followed the instructions verbatim (literally cutting and pasting - the only deviation being the name of the SSID) and I believe that the installation was successful - I can access Kolibri content without issue, both from the device on which Kolibri was installed, as well as from other devices.

However, when attempting to utilize the methods specified for attaching external storage, I seem to be encountering issues - specifically, when I run:

pi@raspberrypi:~ $ sudo systemctl kolibri stop
Unknown operation kolibri.

In an attempt to learn what I could and troubleshoot further, I tried skipping the:

sudo systemctl kolibri stop

and going directly to:

pi@raspberrypi:~ $ kolibri manage movedirectory /media/pi/500 GB Volume

Which results in:

WARNING:root:No C Extensions available for this platform.

INFO Running Kolibri with the following settings: kolibri.deployment.default.settings.base
WARNING Redis is configured without a maximum memory policy. Using Redis with Kolibri, the following is suggested: maxmemory-policy allkeys-lru
WARNING Problematic Redis settings detected, please see Redis configuration documentation for details: Redis configuration – Redis
INFO Invoking command movedirectory /media/pi/500 GB Volume
Unknown command: ‘movedirectory’
Type ‘kolibri manage help’ for usage.

I am completely new to Raspbian, so I apologize in advance if this is an obvious or novice question - I’ve searched the forums and documentation to no avail.

Any assistance is greatly appreciated. Thanks in advance.

Technical details

  • Kolibri 0.14.7
  • Raspbian GNU/Linux 10 (buster) on Raspberry Pi 400 (from Raspberry Pi Imager)
  • Chromium Version 92.0.4515.98 (Official Build) Built on Raspbian , running on Raspbian 10 (32-bit)

Hello @ESP
it seems you’ve found an error in the documentation:
sudo systemctl kolibri stop
should be
sudo systemctl stop kolibri

same with
sudo systemctl kolibri start
it should be
sudo systemctl stop kolibri

I’ll fix the docs, sorry for the inconveniences

Thank you, @jredrejo - the syntax you provided worked, and I was able to successfully move my channels to an external drive. As I’m sure you already noticed, in addition to the issues in the commands you noted, I believe the the command

kolibri manage movedirectory /path/to/your/external_drive

also appears (at least to me) to be incorrect In that particular section of the documentation (Manual setup of a Raspberry Pi — Kolibri User Guide).

(I think it should be:

kolibri manage content movedirectory /path/to/your/external_drive

For others who may find themselves in a similar position before the documentation is updated, the instructions contained in “Change the Location of Kolibri Channels Files” in Advanced Management | Working with Kolibri from the Command Line worked successfully for me:


Thanks for your help.

Thank you for reporting this issue @ESP We’ll fix it asap