MacOS huge problem with installation

I have been struggling with installing Kolibri for a few days now. I tried to install it on a Windows 10 computer and my Mac and both eded up as failures. I looked through the Support forum and found no answer (asked my own question but it is left without the answer either). The problems are as follows:
in my Windows computer I installed Kolibri and now when I want to start it I get a repetitive message that “The server is starting…please wait”.
In my Mac the problem look as follows:

  1. I tried the tips in installation guide found here: - they didn’t work at all, I kept received the message in terminal that the file or directory cannot be find.

  2. So I looked for some help in the forum and I followed this instructions (KOLIBRI 0.7.0 installation on Mac OS):
    $ chmod +x kolibri-v0.7.0.pex
    $ ./kolibri-v0.7.0.pex start
    I was finally able to start the process in terminal, but when I started the process I received this:

Ania-MBP:~ aniaskowron$ /Users/aniaskowron/Downloads/kolibri-v0.7.0.pex ; exit;
Traceback (most recent call last):
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 359, in execute
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 87, in _activate
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 135, in activate
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 179, in _activate
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 124, in update_candidate_distributions
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 110, in load_internal_cache
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 97, in write_zipped_internal_cache
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 178, in cache_distribution
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 124, in safe_open
File “/Users/aniaskowron/Downloads/kolibri-v0.7.0.pex/.bootstrap/_pex/”, line 112, in safe_mkdir
File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/”, line 150, in makedirs
makedirs(head, mode)
File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/”, line 150, in makedirs
makedirs(head, mode)
File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/”, line 157, in makedirs
mkdir(name, mode)
OSError: [Errno 13] Permission denied: ‘/Users/aniaskowron/.pex/install/kolibri-0.7.0-py2.py3-none-any.whl.cf9ae904b8e7982564468df72f83e26182bb3a19.62e9f8987b4a4c439818c455bbe4a574’
Saving session…
…copying shared history…
…saving history…truncating history files…

[Proces zakończony] - Process ended

I would really appreciate your help.

@anka can you post the kolibri server logs here, it is located at C:\Users\YourUsername\.kolibri\server.log in your current Windows 10 Installation.

On MacOS
Can you also try this command in the terminal:
$ chmod 755 /Users/aniaskowron/.pex

If the errors still exist, try to delete the /Users/aniaskowron/.pex directory and run the /kolibri-v0.7.0.pex start command.

Deleting the .pex directory and running the /kolibri-v0.7.0.pex start command worked. Thanks a million! I don’t need the Windows version any more. Again, thank you! Super fast response :slight_smile: