Can I delete the older python version that Kolibri installed?

Kolibri forces you to install python version 3.4 but I already have the last one, is it fine if I uninstall the older python version that kolibri installed? Or will it mess with the program?

1 Like

Hi @Mathias_Velicoff, I think it’s fine to uninstall the older Python you installed before. Just make sure that you reinstall the Kolibri again using the Windows installer. Can you also give us the details about the version of operating system you’re using so we can reproduce and fix it. Thanks.

Hi, thanks for the answer. I’m using windows 10, and I’ll try reinstalling kolibri after uninstalling python, but not sure if that’ll work since I already had the last python version before installing kolibri and there wasn’t any option for skipping the python 3.4 installation and choosing a newer version
I have a log for the kolibri setup where I tried to search if that was possible but only got the ‘python 3.4 is required to install kolibri’ message
Python 3.4+ is required to install Kolibri on Windows; do you wish to first install Python 3.4.3, before continuing with the installation of Kolibri?
2020-06-16 21:01:21.592 User chose No.
2020-06-16 21:01:21.592 Message box (OK/Cancel):
Kolibri cannot run without installing Python. Click Ok to go back and install Python, or Cancel to quit the Kolibri installer

Tried reinstalling, can’t skip the “python 3.4 is required” message, tried uninstalling python 3.4 and opening kolibri since 3.8 is still on my computer, and it didn’t let me open.

Sorry to here that, but the Kolibri Windows is still using the Python 3.4 you need to let the installer
to install it’s built in Python it has pre configured python path to install at your system. We haven’t tested yet the higher new release of Python but I think on our next release we upgraded the built in Python to 3.6.

Hi @Mathias_Velicoff, what version of Kolibri are you using?

Maybe just for now you cannot use the python 3.8 in Windows. because there’s an error when I tried to run it and I filed an issue on this link