Command 'kolibri' not found while setup

Hi, I encountered an error while I was setting up Kolibri in my Ubuntu, which showed command ‘kolibri’ not found, when I tried to run the commands kolibri manage migrate and yarn run devserver. I followed everything step by step in the developer documentation, so I cant understand how to resolve this issue. Please help

Thanks.

Hello @Kej-r03,

Thank you so much for reaching out.

Using the kolibri command requires the successful installation of the project’s python dependencies. Please ensure that you have run the following commands before running the migrate operation.

# required
pip install -r requirements.txt --upgrade
pip install -r requirements/dev.txt --upgrade
pip install -e .

# optional
pip install -r requirements/build.txt --upgrade
pip install -r requirements/test.txt --upgrade
pip install -r requirements/docs.txt --upgrade

I look forward to hearing from you soon!

Thanks, the command worked after proceeding as you instructed, but then I ran into another error in the next command yarn run devserver


Any work around for this

Hi @Kej-r03

Could you please confirm which branch you are running?

Best,

hi, I started setting up the code afresh after deleting the previous one and now it is installed.
Thanks

Hi @Kej-r03,

We are glad that you could setup your development environment successfully. It is very probable that the branch you were running was not up to date with the latest changes. This explains why on deletion and recloning, you were able to successfully setup your dev environment.

Best,