"Kolibri The Server is starting... please wait kolibri.exe"

“Kolibri The Server is starting… please wait kolibri.exe” This message appears and keeps popping up endlessly. After Installation. The browser window http://127.0.0.1:8080 does not open,. I have tried the Kolibri VERSION 0.7.0 on 2 Windows 10 Machines and one Windows 7 System but same problem. Manual stop works. but after start the massage keeps coming up and disapearing. I need urgent help.

Hi @Echota,

Looks like something is blocking Kolibri from starting and opening your browser. Do you have any antivirus or firewall programs on your computers? Could you try adding Kolibri as safe (unblocking it)? Let us know if that helped, and alternatively you can try starting it manually from the command line:

  1. Open the Windows Explorer in the C:\Python27\Scripts folder.
  2. Press the right Shift key and at the same time right click on the Scripts folder.
  3. Select Open command windows here from the contextual menu.
  4. Type kolibri start --debug --foreground in the command prompt window.

If you get a different output from the command then in the image above, copy it here or post a screenshot so we can analyze the error.

This is the error i get when i start kolibri with manually:

C:\Python27\Scripts>kolibri start --debug --foreground
e[37mINFO Running Kolibri with the following settings: kolibri.deployment.default.settings.basee[0m
e[37mINFO Running update routines for new version…e[0m

0 static files copied to ‘C:\Users\enock.kolibri\static’, 407 unmodified.
Operations to perform:
Apply all migrations: sessions, admin, kolibriauth, morango, auth, content, contenttypes, exams, device, logger
Running migrations:
No migrations to apply.
Your models have changes that are not yet reflected in a migration, and so won’t be applied.
Run ‘manage.py makemigrations’ to make new migrations, and then re-run ‘manage.py migrate’ to apply them.
e[37mINFO Running ‘kolibri start’ in foreground…e[0m
Traceback (most recent call last):
File “c:\python27\lib\runpy.py”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “c:\python27\lib\runpy.py”, line 72, in run_code
exec code in run_globals
File "C:\Python27\Scripts\kolibri.exe_main
.py", line 9, in
File “c:\python27\lib\site-packages\kolibri\utils\cli.py”, line 655, in main
start(port, daemon=daemon)
File “c:\python27\lib\site-packages\kolibri\utils\cli.py”, line 326, in start
_, urls = server.get_urls(listen_port=port)
File “c:\python27\lib\site-packages\kolibri\utils\server.py”, line 297, in get_urls
interfaces = ifcfg.interfaces()
File "c:\python27\lib\site-packages\kolibri\dist\ifcfg_init
.py", line 68, in interfaces
return Parser(ifconfig=ifconfig).interfaces
File “c:\python27\lib\site-packages\kolibri\dist\ifcfg\parser.py”, line 29, in init
self.parse(self.ifconfig_data)
File “c:\python27\lib\site-packages\kolibri\dist\ifcfg\parser.py”, line 53, in parse
ifconfig, __, __ = exec_cmd(self.get_command())
File “c:\python27\lib\site-packages\kolibri\dist\ifcfg\tools.py”, line 32, in exec_cmd
stdout = stdout.decode(locale.getpreferredencoding()).encode(‘utf-8’)
File “c:\python27\lib\encodings\cp1252.py”, line 15, in decode
return codecs.charmap_decode(input,errors,decoding_table)
UnicodeDecodeError: ‘charmap’ codec can’t decode byte 0x81 in position 856: character maps to

C:\Python27\Scripts>

@Echota Thank you for providing the details about the error.

I reported the issue on our GitHub repository so our dev team can start working on the fix.

Are you running Windows in English or in some other locale (language)?

My system is in German.
I also tried to install on raspberry pi3 but also receive error saying Python2.7 ist too old. Installing the python to 3.6.3 worked but 2.7 remains default and that is what kolibri is awaiting.

@Echota

Could you try installing this development build to see if it solves the issue you are encountering?

It does not solve the Problem. Still facing the same Error. Has anyone ever managed to get kolibri running on a Windows 10 System?

@Echota Thank you for trying this.

The issue is challenging because for some reason it does not replicate on Windows virtual machines where we do the bulk of our QA testing and debugging… :disappointed:

Could I ask you to delete the whole C:/Users/enock/.kolibri folder and try installing the dev build again?

That i have tried also. it did not produce any results. I will try to build a virtual PC with Windows 10 and try it there

Hi! I love Kolibri but the server does not start on my windows 7 x86. Can you help to do it?

Hi @jmekhteyari -

You can try addressing that issue by following the troubleshooting commands documented here

The issue should also be addressed in our latest release.

Thanks Devon! The problem is solved! Love you!

Just a note in case others continue to experience this problem. In line with the anti-virus software being a potential blocker, we recently had a user report that they couldn’t access Kolibri due to Avast being installed. So it was putting the Python.exe in its ‘Virus Chest’ which was stopping Kolibri from running.

Here are some steps for resolving:

  1. Open Avast.
  2. Click on Protection in the sidebar.
  3. Click on Virus Chest.
  4. Find the file python.exe in the list.
  5. Right click on the file and select ‘Scan’.
  6. If the scan is inconclusive the python.exe file is not infected with a virus.
  7. Right click on the file and select ‘Restore and add to exclusions’.