# Kolibri Login Error

**URL:** <https://community.learningequality.org/t/kolibri-login-error/2281>\
**Category:** Support\
**Created:** [January 12, 2022, 4:22pm UTC](https://community.learningequality.org/t/kolibri-login-error/2281 "2022-01-12T16:22:23Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![k2edutech](https://avatars.discourse-cdn.com/v4/letter/k/a4c791/32.png) [@k2edutech](https://community.learningequality.org/u/k2edutech)\
**Post date:** [January 12, 2022, 4:22pm UTC](https://community.learningequality.org/t/kolibri-login-error/2281/1 "2022-01-12T16:22:24Z")

</div>

The Kolibri had been working fine for more than a month, but today it is giving the following Login Error:  
“Sorry! Something went wrong”.

Here is the system info:  
Version: 0.14.7  
OS: Linux-5.4.0-90-generic-x86\_64-with-glibc2.29  
Python: 3.8.10  
Installer: kolibri(apt) with kolibri-server Version: 0.3.8-0ubuntu1  
Server: nginx/1.18.0 (Ubuntu)

And here is the Error detail:  
{  
“data”: “

# Server Error (500)
”,  
“status”: 500,  
“statusText”: “Internal Server Error”,  
“headers”: {  
“connection”: “keep-alive”,  
“content-length”: “27”,  
“content-type”: “text/html”,  
“date”: “Wed, 12 Jan 2022 16:08:28 GMT”,  
“server”: “nginx/1.18.0 (Ubuntu)”,  
“vary”: “Cookie”,  
“x-frame-options”: “SAMEORIGIN”  
},  
“config”: {  
“url”: “/api/auth/session/”,  
“method”: “post”,  
“params”: {},  
“data”: “{“username”:“aaaaaa”,“password”:”",“facility”:“6933580bce3714aae6099efdb63404e4”}",  
“headers”: {  
“Accept”: “application/json, text/plain, _/_”,  
“Content-Type”: “application/json;charset=utf-8”,  
“X-Requested-With”: “XMLHttpRequest”,  
“X-CSRFToken”: “1gziewLXfBo2ICk7taEVj0tfV0Hkdpxdh35SUbm7PNTyAZU3e5IIKOd60xh1U3WW”  
},  
“transformRequest”: [  
null  
],  
“transformResponse”: [  
null  
],  
“timeout”: 0,  
“xsrfCookieName”: “kolibri\_csrftoken”,  
“xsrfHeaderName”: “X-CSRFToken”,  
“maxContentLength”: -1  
},  
“request”: {}  
}

---

<div class="post-metadata">

**Author:** ![jpierce](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.learningequality.org/jpierce/32/1365_2.png) [@jpierce](https://community.learningequality.org/u/jpierce)\
**Post date:** [January 13, 2022, 7:18pm UTC](https://community.learningequality.org/t/kolibri-login-error/2281/2 "2022-01-13T19:18:14Z")

</div>

Hello k2edutech,

Can you please provide us with the server logs? This might help us better understand what is going on as the error messages from Kolibri itself might identify the cause.

[See here for instructions on where to find the server logs for Kolibri.](https://kolibri.readthedocs.io/en/latest/manage/get_support.html?highlight=logs#locate-kolibri-log-files)

With more information we may be better able to figure out what is going on.

In general, it would be worth doing the following:

- Check your server resources and health itself. Has it run out of hard drive space or might there be any other possible issues there?
- Perhaps try stopping and then restarting the server if you haven’t already.

Best regards,  
Jacob

---

<div class="post-metadata">

**Author:** ![k2edutech](https://avatars.discourse-cdn.com/v4/letter/k/a4c791/32.png) [@k2edutech](https://community.learningequality.org/u/k2edutech)\
**Post date:** [January 15, 2022, 12:02pm UTC](https://community.learningequality.org/t/kolibri-login-error/2281/3 "2022-01-15T12:02:40Z")

</div>

The problem has been solved. The login error occurred after a .cvs file was imported to add USERS in Kolibri. The file contained the same admin USER name that was already in the Kolibri data. This caused the login issue.  
The issue was solved after creating a new admin USER/PWD using commands. Login was done with this new admin, and then the old duplicate admin USER/PWD were deleted.
